Вопрос задан 21.03.2021 в 16:00.
Предмет Информатика.
Спрашивает Рассолова Света.
Напишите программу, которая по номеру дня недели выводит "Рабочий день", если это день с
понедельника по пятницу, или "Суббота" или "Воскресенье". Язык Паскаль.Ответы на вопрос
Отвечает Рыбак Сергей.
var day:integer;
begin
readln(day);
case day of
1..5: writeln('Рабочий день');
6: writeln('Суббота');
7: writeln('Воскресенье');
end;
end.
fpc 3.0.0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Паскаль, которая выводит тип дня недели в зависимости от номера дня:
pascalprogram DayOfWeek; var dayNumber: Integer; begin writeln('Введите номер дня недели (1 - понедельник, 2 - вторник, и т.д.): '); readln(dayNumber); case dayNumber of 1..5: writeln('Рабочий день'); 6: writeln('Суббота'); 7: writeln('Воскресенье'); else writeln('Некорректный номер дня'); end; readln; end.
Программа запрашивает у пользователя ввести номер дня недели от 1 до 7. Затем она использует конструкцию case для проверки значения dayNumber и выводит соответствующий результат.
Пожалуйста, обратите внимание, что вы должны иметь установленную среду разработки Pascal для компиляции и запуска программы.
Топ вопросов за вчера в категории Информатика
Информатика 16
Информатика 13
Информатика 39
Информатика 160
Информатика 65
Информатика 44
Информатика 84
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
