Вопрос задан 21.03.2021 в 03:30. Предмет Информатика. Спрашивает Деркач Влад.

Кто знает с++?Помогите!  Напишите программу, вычисляющую сумму двух целых чисел a и b

( - 10106 < a, b < 10106) Входные данные Даны два целых числа, записанные через пробел. Выходные данные Выведите сумму данных чисел без ведущих нулей.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Соснин Иван.
//Microsoft (R) C/C++ Optimizing Compiler Version 19.00.23506 for x64
#include <iostream>
int main()
{
    int a, b;
    std::cin >> a >> b;
    if ( (a > -10106 && a < 10106) && (b > -10106 && b < 10106) )
        std::cout << a + b;
}
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам написать программу на C++, которая будет вычислять сумму двух целых чисел и выводить результат без ведущих нулей. Вот пример такой программы:

cpp
#include <iostream> #include <string> int main() { int a, b; std::cin >> a >> b; int sum = a + b; std::string result = std::to_string(sum); // Удаление ведущих нулей int leadingZeros = 0; while (result[leadingZeros] == '0') { leadingZeros++; } result = result.substr(leadingZeros); std::cout << result << std::endl; return 0; }

В этой программе мы считываем два целых числа a и b с помощью std::cin. Затем вычисляем их сумму и сохраняем результат в переменной sum. Далее, преобразуем сумму в строку с помощью std::to_string.

Чтобы удалить ведущие нули из строки, мы используем цикл, который находит индекс первого символа, отличного от '0', и сохраняем этот индекс в переменной leadingZeros. Затем мы используем функцию substr для получения подстроки result, начиная с индекса leadingZeros.

Наконец, мы выводим результат без ведущих нулей на экран с помощью std::cout.

Пожалуйста, обратите внимание, что программа предполагает, что ввод будет корректным (два целых числа, разделенных пробелом), и не предусматривает обработку некорректного ввода.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос