
Вопрос задан 20.03.2021 в 04:05.
Предмет Информатика.
Спрашивает Смурага Саша.
Сложные условия ВЕТВЛЕНИЯ ПАСКАЛЬ!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! Напишите программу,
которая получает три числа и выводит количество одинаковых чисел в этой цепочке. Пример: Введите три числа: 5 5 5 Все числа одинаковые. Пример: Введите три числа: 5 7 5 Два числа одинаковые. Пример: Введите три числа: 5 7 8 Нет одинаковых чисел.

Ответы на вопрос

Отвечает Зимин Коля.
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!
begin
case ReadSeqInteger('Введите три целых числа:',3).Distinct.Count of
3:Writeln('Нет одинаковых чисел');
2:Writeln('Два числа одинаковые');
else Writeln('Все числа одинаковые')
end
end.
Примеры
Введите три целых числа: 5 5 5
Все числа одинаковые
Введите три целых числа: 5 7 5
Два числа одинаковые
Введите три целых числа: 5 7 8
Нет одинаковых чисел
// Внимание! Если программа не работает, обновите версию!
begin
case ReadSeqInteger('Введите три целых числа:',3).Distinct.Count of
3:Writeln('Нет одинаковых чисел');
2:Writeln('Два числа одинаковые');
else Writeln('Все числа одинаковые')
end
end.
Примеры
Введите три целых числа: 5 5 5
Все числа одинаковые
Введите три целых числа: 5 7 5
Два числа одинаковые
Введите три целых числа: 5 7 8
Нет одинаковых чисел



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Python, которая решает данную задачу:
python# Ввод трех чисел
num1, num2, num3 = map(int, input("Введите три числа: ").split())
# Проверка на равенство чисел и подсчет количества одинаковых чисел
if num1 == num2 == num3:
print("Все числа одинаковые.")
elif num1 == num2 or num1 == num3 or num2 == num3:
print("Два числа одинаковые.")
else:
print("Нет одинаковых чисел.")
Вы можете скопировать этот код и запустить его в среде разработки Python или воспользоваться онлайн-интерпретатором Python для выполнения программы. После запуска программы она запросит у вас ввести три числа, а затем выдаст соответствующий результат в соответствии с условиями задачи.
Надеюсь, это поможет вам! Если у вас возникнут еще вопросы, не стесняйтесь задавать.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili