
Вопрос задан 19.03.2021 в 10:02.
Предмет Информатика.
Спрашивает Мурлаев Вадим.
Составить программу для определения, является ли натуральное число k степенью числа 3 Borland c


Ответы на вопрос

Отвечает Бобикова Анастасия.
На С++ думаю что то же, что и на С
#include <iostream>
#include <math.h>
using namespace std;
int main() {
int n;
cin>>n;
while (n>2) { n=n/3;}
if (n==1) {cout<<"YES";} else
cout<<"NO";}
#include <iostream>
#include <math.h>
using namespace std;
int main() {
int n;
cin>>n;
while (n>2) { n=n/3;}
if (n==1) {cout<<"YES";} else
cout<<"NO";}



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на языке C, которая определяет, является ли заданное число k степенью числа 3:
c#include <stdio.h>
#include <math.h>
int main()
{
int k;
printf("Введите число: ");
scanf("%d", &k);
int result = log(k) / log(3);
if (result == floor(result)) {
printf("%d является степенью числа 3.", k);
} else {
printf("%d не является степенью числа 3.", k);
}
return 0;
}
Эта программа запрашивает у пользователя натуральное число k, затем вычисляет его логарифм по основанию 3 и проверяет, является ли результат целым числом с помощью функций floor
и ==
. Если результат является целым числом, то k является степенью числа 3, и программа выводит соответствующее сообщение. В противном случае программа сообщает, что k не является степенью числа 3.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili