
Вопрос задан 15.03.2021 в 14:14.
Предмет Информатика.
Спрашивает Воронова Екатерина.
Написать программу на Паскале Дана строка текста напечатать все слова,заканчивающиеся на "ов".
Если можно,то напишите программу с помощью функции Pos

Ответы на вопрос

Отвечает Дусалина Элина.
Считается, что слова отделяются друг от друга пробелом.
var s:string; p:integer;
begin
writeln('Введите строку:');
readln(s);
s:=s+' ';
p:=pos(' ',s);
while p>0 do
begin
if pos('ов ',s)=p-2 then writeln(copy(s,1,p-1));
delete(s,1,p);
p:=pos(' ',s);
end;
end.
Пример:
Введите строку:
пример кров слово шов олово ров
кров
шов
ров
var s:string; p:integer;
begin
writeln('Введите строку:');
readln(s);
s:=s+' ';
p:=pos(' ',s);
while p>0 do
begin
if pos('ов ',s)=p-2 then writeln(copy(s,1,p-1));
delete(s,1,p);
p:=pos(' ',s);
end;
end.
Пример:
Введите строку:
пример кров слово шов олово ров
кров
шов
ров



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на Паскале, которая использует функцию Pos
для поиска слов, заканчивающихся на "ов":
pascalprogram WordsEndingWithOv; uses SysUtils; procedure PrintWordsEndingWithOv(inputString: string); var word: string; startPos, spacePos: Integer; begin spacePos := 0; repeat startPos := spacePos + 1; spacePos := Pos(' ', inputString, startPos); if spacePos = 0 then word := Copy(inputString, startPos, Length(inputString) - startPos + 1) else word := Copy(inputString, startPos, spacePos - startPos); if Length(word) > 2 then begin if Copy(word, Length(word) - 1, 2) = 'ов' then Writeln(word); end; until spacePos = 0; end; var inputString: string; begin WriteLn('Введите строку текста:'); ReadLn(inputString); WriteLn('Слова, заканчивающиеся на "ов":'); PrintWordsEndingWithOv(inputString); end.
Программа запрашивает у пользователя ввод строки текста и затем вызывает функцию PrintWordsEndingWithOv
, которая ищет слова, заканчивающиеся на "ов" с использованием функции Pos
. Затем найденные слова выводятся на экран.
Пожалуйста, обратите внимание, что данная программа считает слова, длина которых больше 2 символов и заканчивается на "ов", как слова, удовлетворяющие условию. Если вы хотите изменить это условие, например, чтобы считать только слова с определенной минимальной длиной, вы можете внести соответствующие изменения в код.


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili