Вопрос задан 12.03.2021 в 13:50.
Предмет Информатика.
Спрашивает Холкина Надя.
Составить программу в Паскале. Даны стороны треугольника а,в,с.Найти его периметр.
Ответы на вопрос
Отвечает Комененко Дмитрий.
Program asd;
Var a,b,c,p :integer;
begin
Write('Введите первую сторону треугольника a: '); readln(a);
Write('Введите вторую сторону треугольника b: '); readln(b);
write('Введите третью сторону треугольника c: '); readln(c);
p:=(a+b+c);
Writeln('Периметр треугольника равен: ',p);
end.
Var a,b,c,p :integer;
begin
Write('Введите первую сторону треугольника a: '); readln(a);
Write('Введите вторую сторону треугольника b: '); readln(b);
write('Введите третью сторону треугольника c: '); readln(c);
p:=(a+b+c);
Writeln('Периметр треугольника равен: ',p);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Паскаль для расчета периметра треугольника по заданным сторонам:
pascalprogram CalculatePerimeter; var a, b, c, perimeter: real; begin // Ввод сторон треугольника writeln('Введите длину стороны а:'); readln(a); writeln('Введите длину стороны b:'); readln(b); writeln('Введите длину стороны c:'); readln(c); // Расчет периметра треугольника perimeter := a + b + c; // Вывод результата writeln('Периметр треугольника: ', perimeter); readln; end.
Программа запрашивает у пользователя значения сторон треугольника a, b и c, а затем вычисляет и выводит их сумму в переменную perimeter, которая и является периметром треугольника.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
