Составьте программу. (Pascal). ПОЖАЛУЙСТА!!!! Заниматься программированием мы будем по рабочим
дням после 18 часов вечера. Введите номер дня недели и время в часах и определите, пришло ли время кодинга.Ответы на вопрос
n = int(input('Ведите время: '))
i = int(input('Введите день недели: '))
if 18 <= n <= 24 and 1 <= i <=5:
print('Время кодинга пришло')
else:
print('Время кодинга не пришло')
Конечно, вот пример программы на Pascal, которая позволит вам определить, наступило ли время кодинга в соответствии с указанными условиями:
pascalprogram ВремяКодинга; var деньНедели: integer; время: integer; begin writeln('Введите номер дня недели (1 - понедельник, 2 - вторник и т.д.): '); readln(деньНедели); writeln('Введите время в часах (от 0 до 23): '); readln(время); if (деньНедели >= 1) and (деньНедели <= 5) and (время >= 18) then begin writeln('Пришло время кодинга! Удачного программирования!'); end else begin writeln('Сейчас не время кодинга. Пожалуйста, подождите до 18 часов вечера в рабочие дни.'); end; readln; end.
Программа запрашивает у пользователя номер дня недели (где 1 - понедельник, 2 - вторник и т.д.) и время в часах (от 0 до 23). Затем она проверяет, является ли указанный день недели рабочим днем (с понедельника по пятницу) и является ли время после 18 часов. Если оба условия выполняются, программа выводит сообщение "Пришло время кодинга! Удачного программирования!" в противном случае выводит сообщение "Сейчас не время кодинга. Пожалуйста, подождите до 18 часов вечера в рабочие дни."
Пожалуйста, обратите внимание, что данная программа представляет лишь пример и не содержит проверок на ошибки ввода или другие дополнительные функции, которые могут быть полезными для более полноценного приложения.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
