Вопрос задан 05.03.2021 в 16:46.
Предмет Информатика.
Спрашивает Трушникова Жанна.
напишите программу вычисляющую площадь и периметр прямоугольника. Стороны прямоугольника вводятся с
клавиатуры.Ответы на вопрос
Отвечает Грибанова Кристина.
Сделал программу на PascalABC, в файле.

Отвечает Бойко Кристина.
Var
a, b, n, p: integer; // Переменные целочисленного типа.
begin
write('Длина: '); readln(a); // Задаём длину нашему треугольнику.
write('Ширина: '); readln(b); // Задаём ширину нашему треугольнику.
n:=a*b // Формула что-бы узнать площадь прямоугольника.
write('Площадь: ',b); // Выводим площадь на экран.
p:=2*a+2*b; // Формула что-бы узнать периметр треугольника.
write('Периметр: ',p); // Выводим периметр на экран.
end.
a, b, n, p: integer; // Переменные целочисленного типа.
begin
write('Длина: '); readln(a); // Задаём длину нашему треугольнику.
write('Ширина: '); readln(b); // Задаём ширину нашему треугольнику.
n:=a*b // Формула что-бы узнать площадь прямоугольника.
write('Площадь: ',b); // Выводим площадь на экран.
p:=2*a+2*b; // Формула что-бы узнать периметр треугольника.
write('Периметр: ',p); // Выводим периметр на экран.
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Python, которая вычисляет площадь и периметр прямоугольника на основе введенных пользователем значений сторон:
python# Ввод сторон прямоугольника с клавиатуры
width = float(input("Введите ширину прямоугольника: "))
height = float(input("Введите высоту прямоугольника: "))
# Вычисление площади прямоугольника
area = width * height
# Вычисление периметра прямоугольника
perimeter = 2 * (width + height)
# Вывод результатов
print("Площадь прямоугольника:", area)
print("Периметр прямоугольника:", perimeter)
Пользователь будет приглашен ввести значения для ширины и высоты прямоугольника, после чего программа вычислит и выведет площадь и периметр.
Обратите внимание, что в этом примере предполагается, что пользователь вводит числовые значения. Если вам нужно обрабатывать возможные ошибки ввода или включать проверки, это можно сделать с помощью дополнительного кода.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 33
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
