
Вопрос задан 24.02.2021 в 22:46.
Предмет Информатика.
Спрашивает Шевырев Никита.
Написать программу в паскале. Дано натуральное число Х.Найти сумму квадратов чётных цифр в числе.


Ответы на вопрос

Отвечает Демидов Артём.
Var
x,d,s:longint;
begin
Writeln('Введите натуральное число: '); Read(x);
s:=0;
while x>0 do begin
d:=x mod 10;
if d mod 2=0 then s:=s+d*d;
x:=x div 10
end;
Writeln('Сумма квадратов четных цифр равна ',s)
end.
Пример
Введите натуральное число:
14702
Сумма квадратов четных цифр равна 20
x,d,s:longint;
begin
Writeln('Введите натуральное число: '); Read(x);
s:=0;
while x>0 do begin
d:=x mod 10;
if d mod 2=0 then s:=s+d*d;
x:=x div 10
end;
Writeln('Сумма квадратов четных цифр равна ',s)
end.
Пример
Введите натуральное число:
14702
Сумма квадратов четных цифр равна 20



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Паскаль, который находит сумму квадратов четных цифр в заданном натуральном числе:
pascalprogram SumOfSquares; var X, digit, sum: integer; begin sum := 0; // Вводим значение Х write('Введите натуральное число X: '); readln(X); // Обрабатываем каждую цифру числа Х while X > 0 do begin digit := X mod 10; // Получаем последнюю цифру числа X := X div 10; // Удаляем последнюю цифру числа // Проверяем, является ли цифра четной if digit mod 2 = 0 then sum := sum + sqr(digit); // Добавляем квадрат четной цифры к сумме end; // Выводим результат writeln('Сумма квадратов четных цифр в числе: ', sum); readln; end.
Программа запрашивает у пользователя ввод натурального числа Х, затем обрабатывает каждую цифру числа. Если цифра четная, то ее квадрат добавляется к сумме. В конце программа выводит полученную сумму квадратов четных цифр.
Обратите внимание, что в данной программе предполагается, что пользователь вводит корректное натуральное число Х без ведущих нулей.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili