напишите программу которая в зависимости от введенной оценки в диапазоне от 1 до 12 выводит уровень
к которому она относится C++Ответы на вопрос
#include <iostream>
using namespace std;
int main() {
int n;
cin>>n;
switch (n)
{
case 1:
case 2:
case 3:
cout<<"Неудовлетворительно";
break;
case 4:
case 5:
case 6:
cout<<"Удовлетворительно";
break;
case 7:
case 8:
case 9:
cout<<"Хорошо";
break;
case 10:
case 11:
case 12:
cout<<"Отлично";
break;
default: cout<<"Ошибка ввода";
}
return 0;
}
_________________________
Вот сам макет программы. Если нужны дугие уровни оценок - можно просто заменить выводимый текст на требуемый.
Конечно! Вот пример программы на языке C++, которая принимает оценку от пользователя и выводит соответствующий уровень:
cpp#include <iostream>
using namespace std;
int main() {
int оценка;
cout << "Введите оценку (от 1 до 12): ";
cin >> оценка;
switch (оценка) {
case 1:
case 2:
case 3:
cout << "Уровень: Низкий" << endl;
break;
case 4:
case 5:
case 6:
cout << "Уровень: Средний" << endl;
break;
case 7:
case 8:
case 9:
cout << "Уровень: Высокий" << endl;
break;
case 10:
case 11:
case 12:
cout << "Уровень: Очень высокий" << endl;
break;
default:
cout << "Некорректная оценка" << endl;
break;
}
return 0;
}
В этой программе мы используем оператор switch для сравнения значения оценка с различными случаями. В каждом случае выводится соответствующий уровень в зависимости от оценки, а если введена некорректная оценка, выводится сообщение об ошибке.
Обратите внимание, что я использую кириллические символы в переменной "оценка" в соответствии с вашим запросом. Однако, если вам нужно использовать английские символы, просто измените имя переменной на "grade" и соответствующие сообщения вывода на английском языке.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
