Вопрос задан 23.02.2021 в 17:07.
Предмет Информатика.
Спрашивает Нестерко Іван.
Помогите написать программу в Pascal, которая вычисляет среднюю оценку за неделю (с помощью
массивов)Ответы на вопрос
Отвечает Руснак Діана.
//PascalABC.Net
begin
var a: array of integer;
setLength (a, readinteger('Введите кол-во учеников: '));
for var i:=0 to length(a)-1 do a[i]:=readinteger ('Введите оценку ученика: ');
write ('Средняя оценка: ', a.Average);
end.
begin
var a: array of integer;
setLength (a, readinteger('Введите кол-во учеников: '));
for var i:=0 to length(a)-1 do a[i]:=readinteger ('Введите оценку ученика: ');
write ('Средняя оценка: ', a.Average);
end.
Отвечает Дмитриенко Софья.
Program n1;
const n=12;
var a: array[1..n] of integer;
i,sum: integer;
begin
randomize;
sum:=0;
write('оценки за неделю: ');
for i:=1 to n do
begin
a[i]:=random(4)+2;
write(a[i],' ');
end;
writeln;
for i:=1 to n do sum:=sum+a[i];
writeln('среднее арифмитическое: ',sum/n);
end.
const n=12;
var a: array[1..n] of integer;
i,sum: integer;
begin
randomize;
sum:=0;
write('оценки за неделю: ');
for i:=1 to n do
begin
a[i]:=random(4)+2;
write(a[i],' ');
end;
writeln;
for i:=1 to n do sum:=sum+a[i];
writeln('среднее арифмитическое: ',sum/n);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я могу помочь вам написать программу на Pascal для вычисления средней оценки за неделю с использованием массивов. Вот пример решения:
pascalprogram AverageGrade; const DaysPerWeek = 7; var grades: array[1..DaysPerWeek] of Integer; day: Integer; sum, average: Real; begin sum := 0; // Ввод оценок за каждый день недели for day := 1 to DaysPerWeek do begin Write('Введите оценку за день ', day, ': '); ReadLn(grades[day]); sum := sum + grades[day]; end; // Вычисление средней оценки average := sum / DaysPerWeek; // Вывод результатов WriteLn('Средняя оценка за неделю: ', average:0:2); // Задержка консоли перед завершением программы ReadLn; end.
В этой программе используется массив grades, размер которого равен DaysPerWeek (7). Вы вводите оценки для каждого дня недели, и программа вычисляет и выводит среднюю оценку за неделю.
Обратите внимание, что данная программа предполагает, что оценки вводятся целыми числами. Если вам нужно работать с оценками с плавающей точкой, измените тип массива и переменных соответственно.
Вы можете скопировать приведенный код и запустить его в Pascal-совместимой среде разработки, такой как Free Pascal или Turbo Pascal, чтобы увидеть результаты выполнения программы.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
