
Вопрос задан 23.02.2021 в 15:22.
Предмет Информатика.
Спрашивает Сембекова Акмаржан.
Помогите написать программу-функцию для нахождения числа в определенной степени .С++


Ответы на вопрос

Отвечает Пушкарёв Евгений.
#include <iostream>
#include <math.h>
using namespace std;
int Calc(int ch, int step)
{
int result = pow(ch, step);
return result;
}
int main()
{
int ch, step, result;
cout « "Enter number: "; cin » ch;
cout « "Enter step: "; cin » step;
result = Calc(ch, step);
cout « endl « "Result = " « result « endl;
return 0;
}
#include <math.h>
using namespace std;
int Calc(int ch, int step)
{
int result = pow(ch, step);
return result;
}
int main()
{
int ch, step, result;
cout « "Enter number: "; cin » ch;
cout « "Enter step: "; cin » step;
result = Calc(ch, step);
cout « endl « "Result = " « result « endl;
return 0;
}





Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке C++, которая находит число в определенной степени:
cpp#include <iostream>
#include <cmath>
double power(double base, int exponent) {
double result = pow(base, exponent);
return result;
}
int main() {
double base;
int exponent;
std::cout << "Введите число: ";
std::cin >> base;
std::cout << "Введите степень: ";
std::cin >> exponent;
double result = power(base, exponent);
std::cout << base << " в степени " << exponent << " равно " << result << std::endl;
return 0;
}
Эта программа определяет функцию power
, которая принимает два аргумента: base
(основание числа) и exponent
(степень). В функции используется функция pow
из библиотеки <cmath>
, которая возводит число в заданную степень. Функция power
возвращает результат возведения в степень.
В функции main
пользователю предлагается ввести число и степень. Затем вызывается функция power
, передавая в нее введенные значения, и результат выводится на экран.
Вы можете скомпилировать и запустить эту программу, чтобы проверить ее работу.


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili