Вопрос задан 22.02.2021 в 00:33. Предмет Информатика. Спрашивает Олійник Каріна.

Напишите программу нахождения суммы и произведения 10 случайных чисел. Pascal.​

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Буслаева Настя.

Ответ:const

n=10;

var

a:array[1..n]of integer;

i:integer;

s,p:real;

  begin

randomize;

p:=1;

        for i:=1 to n do

             begin

                  a[i]:=random(100)-50;

                  write(a[i]:4);

                  p:=p*a[i]  ;

                  s:=s+a[i];

             end;

writeln;

writeln(P = ,p,   S= ,s);

end.

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на языке Pascal, которая находит сумму и произведение 10 случайных чисел:

pascal
program SumAndProduct; var i, number, sum, product: Integer; begin Randomize; // Инициализация генератора случайных чисел sum := 0; product := 1; for i := 1 to 10 do begin number := Random(100); // Генерация случайного числа от 0 до 99 writeln('Случайное число ', i, ': ', number); sum := sum + number; product := product * number; end; writeln('Сумма чисел: ', sum); writeln('Произведение чисел: ', product); readln; end.

В этом примере мы используем функцию Randomize, чтобы инициализировать генератор случайных чисел, и функцию Random, чтобы генерировать случайные числа в диапазоне от 0 до 99. Затем мы выполняем цикл for, чтобы сгенерировать 10 случайных чисел, находить их сумму и произведение, и выводим результаты на экран.

Обратите внимание, что в Pascal индексация массивов начинается с 1, поэтому цикл for выполняется от 1 до 10.

Надеюсь, это поможет вам! Если у вас возникнут дополнительные вопросы, не стесняйтесь задавать.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос