Вопрос задан 20.02.2021 в 17:34.
Предмет Информатика.
Спрашивает Галанов Вова.
Написать программу для вычисления цены ткани, количество и стоимость вводятся с клавиатуры Pascal
Ответы на вопрос
Отвечает Крапицкая Валерия.
Var
k, c: integer;
begin
write('Введите количество: ');
readln(k);
write('Введите стоимость: ');
readln(c);
writeln('Цена равна ', c/k);
end.
k, c: integer;
begin
write('Введите количество: ');
readln(k);
write('Введите стоимость: ');
readln(c);
writeln('Цена равна ', c/k);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Pascal, которая вычисляет стоимость ткани на основе введенного пользователем количества и цены:
pascalprogram Вычисление_стоимости_ткани; var количество: integer; цена: real; стоимость: real; begin writeln('Введите количество ткани:'); readln(количество); writeln('Введите цену за метр ткани:'); readln(цена); стоимость := количество * цена; writeln('Общая стоимость ткани: ', стоимость:0:2); readln; end.
В этой программе мы используем переменные количество, цена и стоимость. Сначала мы запрашиваем у пользователя количество ткани и цену за метр. Затем вычисляем общую стоимость, умножая количество на цену. Наконец, выводим результат на экран.
Программа ожидает ввода данных с клавиатуры и выводит результат на экран. После вывода результата программа ждет, пока пользователь нажмет клавишу Enter, чтобы закрыть окно консоли.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
