Вопрос задан 15.02.2021 в 11:30. Предмет Информатика. Спрашивает Потокин Вова.

В среде программирования Quick Basic составить программу для нахождения суммы последовательности

чисел произвольного диапазона. Проверить работу программы для чисел от 5 до 12
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Галямшина Алина.

var i,d,a,b: integer;
begin
cls;
writeln('введите кол-во чисел');
readln(a,b);
d:=1;
for i:=a to b do d:=d+1;
writeln('cумма=',d);
end.

забиваем числа 5 и 12 их сумма  равняется 9

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке Quick Basic, которая находит сумму последовательности чисел в заданном диапазоне:

basic
CLS INPUT "Введите начало диапазона: "; start INPUT "Введите конец диапазона: "; end IF start > end THEN PRINT "Ошибка: начало диапазона больше конца диапазона" ELSE sum = 0 FOR i = start TO end sum = sum + i NEXT i PRINT "Сумма чисел в диапазоне от "; start; " до "; end; " равна "; sum ENDIF END

При запуске программы она попросит вас ввести начало и конец диапазона. В данном случае вы должны ввести 5 и 12 соответственно. Затем программа вычислит сумму всех чисел в указанном диапазоне и выведет результат на экран.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос