Вопрос задан 14.02.2021 в 17:38.
Предмет Информатика.
Спрашивает Нестеренко Снежана.
В программе Pascal ABC составьте программу, которая вычисляет произведение n чисел вводимых с
клавиатуры.Ответы на вопрос
Отвечает Леонов Макс.
Var
sum, k, n, i: integer;
begin
sum := 0;
write('n: ');
readln(n);
for i := 1 to n do
begin
readln(k);
sum := sum + k;
end;
writeln('sum = ', sum);
end.
sum, k, n, i: integer;
begin
sum := 0;
write('n: ');
readln(n);
for i := 1 to n do
begin
readln(k);
sum := sum + k;
end;
writeln('sum = ', sum);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Pascal ABC, которая вычисляет произведение n чисел, вводимых с клавиатуры:
pascalprogram Вычисление_произведения; var n, i: integer; число, произведение: real; begin произведение := 1; // Инициализируем произведение единицей write('Введите количество чисел: '); readln(n); for i := 1 to n do begin write('Введите число ', i, ': '); readln(число); произведение := произведение * число; end; writeln('Произведение введенных чисел: ', произведение:0:2); readln; end.
Пользователю будет предложено ввести количество чисел, а затем они будут запрошены по одному. Программа будет последовательно умножать введенные числа друг на друга и выводить итоговое произведение.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
