Вопрос задан 13.02.2021 в 12:45.
Предмет Информатика.
Спрашивает Фаизов Ильнур.
ОЧЕЕЕЕЕЕЕЕЕЕЕЕНЬ СРОЧНО 1)Составьте программу которая заполняет массив a[1..10] случайными целыми
числами в диапазоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с нечетными значениями в три раза, а элементы с четными значениями заменяя на 0. 2)Составьте программу, которая заполняет массив а[1..10] случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый и последний элементы.Выведите на экран исходный и полученный массивы. Это нужно через PascalABC. ЗАРАНЕЕ ОГРОМНОЕ СПАСИБООтветы на вопрос
Отвечает Евдокимов Данила.
1) var a:array [1..10] of integer;
i:integer;
begin
writeln('Генерируем массив со случайными числами');
for i:=1 to 10 do begin
a[i]:=random(100)+1;
write(a[i],' ');
end;
writeln;
writeln('Выполняем действие');
for i:=1 to 10 do begin
if (i mod 2 = 0) then a[i]:=0 else a[i]:=a[i]*3;
write(a[i],' ');
end;
readln;
end.
2) var a:array [1..10] of integer;
i,k:integer;
begin
writeln('Генерируем массив со случайными числами');
for i:=1 to 10 do begin
a[i]:=random(100)+1;
write(a[i],' ');
end;
writeln;
writeln('Выполняем действие');
k:=a[1];
a[1]:=a[10];
a[10]:=k;
for i:=1 to 10 do write(a[i],' ');
readln;
end.
i:integer;
begin
writeln('Генерируем массив со случайными числами');
for i:=1 to 10 do begin
a[i]:=random(100)+1;
write(a[i],' ');
end;
writeln;
writeln('Выполняем действие');
for i:=1 to 10 do begin
if (i mod 2 = 0) then a[i]:=0 else a[i]:=a[i]*3;
write(a[i],' ');
end;
readln;
end.
2) var a:array [1..10] of integer;
i,k:integer;
begin
writeln('Генерируем массив со случайными числами');
for i:=1 to 10 do begin
a[i]:=random(100)+1;
write(a[i],' ');
end;
writeln;
writeln('Выполняем действие');
k:=a[1];
a[1]:=a[10];
a[10]:=k;
for i:=1 to 10 do write(a[i],' ');
readln;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот программы на языке PascalABC, которые выполняют указанные вами задачи:
- Программа, заполняющая массив случайными числами и преобразующая его:
pascalprogram ArrayTransformation; var a: array[1..10] of Integer; i: Integer; begin Randomize; { Заполнение массива случайными числами } for i := 1 to 10 do a[i] := Random(10) + 1; { Преобразование массива } for i := 1 to 10 do begin if a[i] mod 2 = 1 then { нечетное значение } a[i] := a[i] * 3 else { четное значение } a[i] := 0; end; { Вывод исходного массива } WriteLn('Исходный массив:'); for i := 1 to 10 do Write(a[i], ' '); { Вывод преобразованного массива } WriteLn; WriteLn('Преобразованный массив:'); for i := 1 to 10 do Write(a[i], ' '); ReadLn; end.
- Программа, заполняющая массив случайными числами и меняющая местами первый и последний элементы:
pascalprogram SwapArrayElements; var a: array[1..10] of Integer; temp: Integer; i: Integer; begin Randomize; { Заполнение массива случайными числами } for i := 1 to 10 do a[i] := Random(10) + 1; { Вывод исходного массива } WriteLn('Исходный массив:'); for i := 1 to 10 do Write(a[i], ' '); { Меняем местами первый и последний элементы } temp := a[1]; a[1] := a[10]; a[10] := temp; { Вывод полученного массива } WriteLn; WriteLn('Полученный массив:'); for i := 1 to 10 do Write(a[i], ' '); ReadLn; end.
Надеюсь, эти программы вам помогут! Если у вас возникнут еще вопросы, не стесняйтесь задавать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
