Вопрос задан 13.02.2021 в 10:11.
Предмет Информатика.
Спрашивает Береговая Света.
Написать на Pascal abc Всем известно, что многие олимпиадные задачи начинаются со слов «Всем
известно». Но мало кто знает, что начинающему программисту Паше такие задачи меньше всего нравятся. Потому что обычно после слов «всем известно» описывается такой факт, о котором он даже не догадывался. После очередной подобной задачи Паша решил проверить, а действительно ли всем известно, что сумма первых N нечетных чисел равняется N2:Для этого Паша провел опрос всех людей, попавшихся ему под руку в известной социальной сети. Результаты опроса он записал в текстовый файл. Он ставил цифру один, если человеку был действительно известен данный факт, в противном случае в файл записывался нуль. Все было хорошо, пока Паша не открыл файл и не ужаснулся, увидев длинную последовательность из единичек. Как же он теперь будет искать среди них нули?Уже всем известно, что Паша – начинающий программист, поэтому для обработки результатов исследования он обратился к вам за помощью.Входные данныеВходной файл INPUT.TXT содержит непустую последовательность из нулей и единиц. Длина последовательности не превышает 10^4.Выходные данныеВ выходной файл OUTPUT.TXT выведите слово «YES», если факт был известен всем опрошенным людям, и слово "NO" в противном случае.Примеры№ INPUT.TXT OUTPUT.TXT1 11111101010011. NO2 11 YESОтветы на вопрос
Отвечает Щёлокова Елизавета.
Ответ:
var t1,t2:text; c:char; f:boolean;
begin
assign(t1,'INPUT.TXT');
reset(t1);
assign(t2,'OUTPUT.TXT');
rewrite(t2);
f:=true;
while not eof(t1) and f do
begin
read(t1,c);
f:=f and (c='1');
end;
if f then writeln(t2,'YES')
else writeln(t2,'NO');
close(t1);
close(t2);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Привет! Вот пример решения задачи на языке Pascal:
pascalprogram Main; var inputFile, outputFile: TextFile; sequence: string; i, zerosCount: integer; factKnown: boolean; begin // Открываем файлы для чтения и записи AssignFile(inputFile, 'INPUT.TXT'); AssignFile(outputFile, 'OUTPUT.TXT'); Reset(inputFile); Rewrite(outputFile); // Считываем последовательность из файла ReadLn(inputFile, sequence); // Предполагаем, что факт известен всем factKnown := true; // Проверяем наличие нулей в последовательности zerosCount := 0; for i := 1 to Length(sequence) do begin if sequence[i] = '0' then Inc(zerosCount); // Если есть нули, то факт не известен всем if zerosCount > 0 then begin factKnown := false; Break; end; end; // Записываем результат в файл if factKnown then WriteLn(outputFile, 'YES') else WriteLn(outputFile, 'NO'); // Закрываем файлы CloseFile(inputFile); CloseFile(outputFile); end.
Данный код открывает файлы INPUT.TXT и OUTPUT.TXT, считывает последовательность из первого файла, проверяет наличие нулей в последовательности и записывает результат во второй файл.
Надеюсь, это поможет! Если у тебя возникнут еще вопросы, не стесняйся задавать.
Топ вопросов за вчера в категории Информатика
Информатика 20
Информатика 23
Информатика 21
Информатика 29
Информатика 21
Информатика 20
Информатика 25
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
