Вопрос задан 16.06.2018 в 06:14.
Предмет Информатика.
Спрашивает Абдимомин Санжар.
В паскале написать программу: Вывести среднее арифметическое двузначных четных чисел
Ответы на вопрос
Отвечает Фесенко Надежда.
Const
n=20;
var
a:array[1..n]of integer;
i,k:integer;
s:real;
begin
for i:=1 to n do
begin
a[i]:=random(201)-100;
write(a[i]:4);
if (a[i]>=10)and(a[i]<100)and(a[i]mod 2=0)then
begin
s:=s+a[i];
k:=k+1;
end;
end;writeln;
if k<>0 then
writeln(s/k:4:2)
else
writeln('нет четных двузначных');
end.
Отвечает Шичанин Денис.
Var i,k:integer;
rez:real;
begin
for i:=10 to 99 do
if (i mod 2)=0 then
begin
k:=k+1;
rez:=rez+i;
end;
rez:=rez/k;
writeln(rez:0:1);
end.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 33
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
