Вопрос задан 01.12.2020 в 11:48.
Предмет Информатика.
Спрашивает Воленчук Дашенька.
Написать программу, которая определит все четырёхзначные числа являющиеся симметричными, т.е abcd
a+b=c+d и вывести на экран через пробелы, посчитав при этом их количествоОтветы на вопрос
Отвечает Вележева Алиса.
Program n;
uses crt;
var i,a,b,c,d,k:integer;
begin
k:=0;
for i:=1000 to 9999 do begin
a:=i div 1000;
b:=i div 100 mod 10;
c:=i div 10 mod 10;
d:=i mod 10;
if a+b=c+d then begin
write(i,' '); k:=k+1; end;
end; writeln;
writeln(k,' шт'');
end.
uses crt;
var i,a,b,c,d,k:integer;
begin
k:=0;
for i:=1000 to 9999 do begin
a:=i div 1000;
b:=i div 100 mod 10;
c:=i div 10 mod 10;
d:=i mod 10;
if a+b=c+d then begin
write(i,' '); k:=k+1; end;
end; writeln;
writeln(k,' шт'');
end.
Топ вопросов за вчера в категории Информатика
Информатика 11
Информатика 1255
Информатика 115
Информатика 1220
Информатика 11
Информатика 10
Информатика 66
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
