
Вопрос задан 11.11.2020 в 19:04.
Предмет Информатика.
Спрашивает Маслов Данила.
Составить программу вычисления суммы ряда s:=1+2+3+4+5+6


Ответы на вопрос

Отвечает Свищ Віка.
Program summa;
uses crt;
Var s, i, n:integer;
begin
Write('n=') ;readln(n) ;
s:=1; write('s=1') ;
For i:=2 to n do
Begin
s:=s+i;
Write('+', i) ;
End;
Write('=', s) ;
readln;
end.
uses crt;
Var s, i, n:integer;
begin
Write('n=') ;readln(n) ;
s:=1; write('s=1') ;
For i:=2 to n do
Begin
s:=s+i;
Write('+', i) ;
End;
Write('=', s) ;
readln;
end.



Отвечает Терелёв Артём.
1. Самый незатейливый вариант, выдающий значение суммы 21
begin
Writeln(1+2+3+4+5+6)
end.
2. Типовой "школьный вариант"
var
i,s:integer;
begin
s:=0;
for i:=1 to 6 do s:=s+i;
Writeln(s)
end.
3. Современный вариант, немного покороче
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!
begin
1.To(6).Sum.Println
end.
begin
Writeln(1+2+3+4+5+6)
end.
2. Типовой "школьный вариант"
var
i,s:integer;
begin
s:=0;
for i:=1 to 6 do s:=s+i;
Writeln(s)
end.
3. Современный вариант, немного покороче
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!
begin
1.To(6).Sum.Println
end.


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili