Вопрос задан 09.11.2020 в 01:55. Предмет Информатика. Спрашивает Гвоздик Кузьма.

PASCAL Написать программу для нахождения принадлежности точки с координатами x,y заштрихованной

области
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Марышева Женя.
У меня получилось вот так...
Пожалуйста, протестируй программу обязательно!

uses Crt;
  var X,Y: real;
      bol: boolean;
begin
 ClrScr;
 Write(' X = ');  ReadLn(X);
 Write(' Y = ');  ReadLn(Y);
 bol:=(Y>=0) and (Y<=sqrt(9-x*x)) and (Y<=3-X/2);
 if bol=true then Writeln (' Yes!!!')
             else WriteLn (' No...');
 ReadLn;
end.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос