Вопрос задан 02.09.2020 в 09:35. Предмет Информатика. Спрашивает Бондар Лера.

Написать программу удаления половины символов, зная, что количество символов в строке - чётное.

(Паскаль)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке Паскаль, которая удаляет половину символов из строки, при условии, что количество символов в строке является четным:

```pascal program RemoveHalfChars;

var str: string; i: integer;

begin // Ввод строки write('Введите строку: '); readln(str);

// Проверка на четность количества символов if Length(str) mod 2 = 0 then begin // Удаление половины символов for i := Length(str) div 2 downto 1 do Delete(str, i, 1);

// Вывод результата writeln('Результат: ', str); end else writeln('Количество символов в строке не является четным.'); end. ```

Программа сначала запрашивает у пользователя ввод строки. Затем она проверяет, является ли количество символов в строке четным числом. Если это так, то программа удаляет половину символов из строки, начиная с середины и до начала строки. В конце программа выводит полученный результат.

Примечание: Программа написана на языке Паскаль. Если вы хотите написать программу на другом языке программирования, пожалуйста, уточните это.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос