
1)составить программу, которая подсчитает объем любого шара по формуле: V=4/3Пr^3 2)даны
действительные числа x и y. необходимо определить принадлежит ли точка с координатами (x,y) окружности с радиусом R и центром в точке (x1,y1). 3)дан одномерный числовой массиф В(16). Необходимо вывести на экран индексы элементов значения, которых равны числу P. cрочно надо на языке паскаль составить плиз)

Ответы на вопрос

1) Программа для подсчета объема шара по формуле V = (4/3) * П * r^3: ```pascal program CalculateSphereVolume; var r, V: real; begin writeln('Введите радиус шара:'); readln(r); V := (4/3) * 3.14159 * r * r * r; writeln('Объем шара равен: ', V); end. ``` Источник 1: [Pascal Tutorial - Learn Pascal Programming Language](https://www.programiz.com/pascal-programming/tutorial)
2) Программа для определения принадлежности точки (x, y) окружности с радиусом R и центром в точке (x1, y1): ```pascal program CheckPointOnCircle; var x, y, x1, y1, R: real; distance: real; begin writeln('Введите координаты точки (x, y):'); readln(x, y); writeln('Введите координаты центра окружности (x1, y1):'); readln(x1, y1); writeln('Введите радиус окружности:'); readln(R); distance := sqrt((x - x1) * (x - x1) + (y - y1) * (y - y1)); if distance = R then writeln('Точка принадлежит окружности.') else writeln('Точка не принадлежит окружности.'); end. ``` Источник 2: [Pascal Tutorial - Learn Pascal Programming Language](https://www.programiz.com/pascal-programming/tutorial)
3) Программа для вывода индексов элементов массива B[16], значения которых равны числу P: ```pascal program FindIndexesOfP; var B: array[1..16] of integer; P, i: integer; begin writeln('Введите значения элементов массива B[16]:'); for i := 1 to 16 do readln(B[i]); writeln('Введите число P:'); readln(P); writeln('Индексы элементов, значения которых равны числу P:'); for i := 1 to 16 do begin if B[i] = P then writeln(i); end; end. ``` Источник 3: [Pascal Tutorial - Learn Pascal Programming Language](https://www.programiz.com/pascal-programming/tutorial)


Топ вопросов за вчера в категории Информатика








Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili