Вопрос задан 11.06.2018 в 11:12. Предмет Информатика. Спрашивает Котик Дима.

Помогите пожалуйста. (Напишите программу которая преобразует угол из градусной меры в радианную.

Результат выводится на экран) в pascal ABC
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Алексеева Леся.

Var s:real;d:double;
begin 
Read(s);
d:= s*3.2425926/180;
write(s,' градусов = ',d,' радиан');
end.

0 0
Отвечает Крот Егор.

//PascalABC.Net 3.0, сборка 1052
var
  d:single;
begin
  Write('Введите угол в градусах: '); Read(d);
  Writeln('Угол в радианах: ',DegToRad(d))
end.

Тестовое решение:
Введите угол в градусах: 57.3
Угол в радианах: 1.00007364807695

Вариант с формулой вместо функции:
//PascalABC.Net 3.0, сборка 1052
var
  d:single;
begin
  Write('Введите угол в градусах: '); Read(d);
  Writeln('Угол в радианах: ',Pi*d/180)
end.

Вариант, если не хочется использовать константу Pi:
//PascalABC.Net 3.0, сборка 1052
var
  d:single;
begin
  Write('Введите угол в градусах: '); Read(d);
  Writeln('Угол в радианах: ',ArcTan(1)*d/45)
end.

Вариант для тех, кто не помнит, что arctg(1)=π/4:
//PascalABC.Net 3.0, сборка 1052
const
  Pi=3.14;
var
  d:single;
begin
  Write('Введите угол в градусах: '); Read(d);
  Writeln('Угол в радианах: ',Pi*d/180)
end.

Тестовое решение для этого случая:
Введите угол в градусах: 57.3
Угол в радианах: 0.999566653357612

Как видно, из-за значения π, заданного с низкой точностью, снизилась и точность результата.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос