Вопрос задан 01.08.2020 в 07:37.
Предмет Информатика.
Спрашивает Матвейкин Кирилл.
Помогите пожалуйста написать программу))) Даны два числа. Наименьшее из этих чисел возвести в
квадрат, наибольшее в куб. Найти среднее арифметическое полученных данных.Ответы на вопрос
Отвечает Коротков Рома.
Program gt;
var a,b,s,q:real;
begin
readln(a,b);
q:=0;
if(a>b)then begin
a:=a*a*a;
b:=b*b;
q:=1;
end;
if(q=0)then begin
b:=b*b*b;
a:=a*a;
end;
s:=(a+b)/2;
writeln(a,' ',b,' ',s);
end.
var a,b,s,q:real;
begin
readln(a,b);
q:=0;
if(a>b)then begin
a:=a*a*a;
b:=b*b;
q:=1;
end;
if(q=0)then begin
b:=b*b*b;
a:=a*a;
end;
s:=(a+b)/2;
writeln(a,' ',b,' ',s);
end.
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 37
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
