Вопрос задан 31.07.2020 в 21:30. Предмет Информатика. Спрашивает Бычкова Екатерина.

Написать программу Паскаль тремя способами ( с предусловием, постусловием, со счетчиком) Срочноооо


0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Соромотина Катя.
1
var 
i: byte := 1; 
sum: integer := 0;
begin 
//Предусловие 
writeln('*** Цикл с предусловием ***'); 
while i <= 100 do 
begin   
sum := sum + i;   
inc(i); 
end; 
writeln('Сумма = ', sum:5); 
//Постусловие 
sum := 0; i := 1; 
writeln('*** Цикл с постусловием ***'); 
repeat   
sum := sum + i;   
inc(i); 
until i > 100; 
writeln('Сумма = ', sum:5); 
//Счетчик 
sum := 0; 
writeln('*** Счетчик ***'); 
for i := 1 to 100 do sum := sum + i; 
writeln('Сумма = ', sum:5);
end.

2
var 
N: integer; 
i: integer := 1; 
sum: integer := 0;
begin 
write('Введите N: '); 
readln(N); 
//Предусловие 
writeln('*** Цикл с предусловием ***'); 
while i <= n do 
begin   
sum := sum + i;   
inc(i); 
end; 
writeln('Сумма = ', sum:5); 
//Постусловие 
sum := 0; i := 1; 
writeln('*** Цикл с постусловием ***'); 
repeat   
sum := sum + i;   
inc(i); 
until i > N; 
writeln('Сумма = ', sum:5); 
//Счетчик 
sum := 0; 
writeln('*** Счетчик ***'); 
for i := 1 to N do sum := sum + i; 
writeln('Сумма = ', sum:5);
end.
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос