Вопрос задан 02.07.2020 в 08:35.
Предмет Информатика.
Спрашивает Афонин Денис.
Составьте программу, вычисляющую, сколько раз в строке X встречается слово Y. Строку X и слово Y
введите с клавиатуры.Ответы на вопрос
Отвечает Панов Игнат.
Var x,y,z:string; k,p,l:integer;
begin
writeln('Введите строку:');
readln(x);
writeln('Введите слово:');
readln(y);
z:=x; k:=0;
l:=length(y);
p:=pos(y,x);
while p>0 do
begin
k:=k+1;
delete(z,p,l);
p:=pos(y,z);
end;
writeln('k = ',k);
end.
Пример:
Введите строку:
мама мыла раму, мама мыла окно.
Введите слово:
мама
k = 2
begin
writeln('Введите строку:');
readln(x);
writeln('Введите слово:');
readln(y);
z:=x; k:=0;
l:=length(y);
p:=pos(y,x);
while p>0 do
begin
k:=k+1;
delete(z,p,l);
p:=pos(y,z);
end;
writeln('k = ',k);
end.
Пример:
Введите строку:
мама мыла раму, мама мыла окно.
Введите слово:
мама
k = 2
Топ вопросов за вчера в категории Информатика
Информатика 16
Информатика 13
Информатика 39
Информатика 160
Информатика 65
Информатика 44
Информатика 84
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
