Вопрос задан 26.06.2020 в 21:25.
Предмет Информатика.
Спрашивает Новиков Вадим.
Составить программу нахождения для заданного натурального числа всех делителей, кратных
числу .Формат входных данных Входной файл содержит числа , ().Формат выходных данныхВыведите искомые делители.Примеры:Вход6 3Выход3 6Ответы на вопрос
Отвечает Еремеев Сергей.
#include <iostream>
using namespace std;
int main()
{
int a,b;
cin >> a >> b;
for (int i = 1; i <= a; i++)
{
if (a%i == 0)
{
if (i%b == 0)
{
cout << i << ' ';
}
}
}
system("pause");
}
using namespace std;
int main()
{
int a,b;
cin >> a >> b;
for (int i = 1; i <= a; i++)
{
if (a%i == 0)
{
if (i%b == 0)
{
cout << i << ' ';
}
}
}
system("pause");
}
Топ вопросов за вчера в категории Информатика
Информатика 14
Информатика 2231
Информатика 86
Информатика 50
Информатика 234
Информатика 31
Информатика 31
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
