Вопрос задан 13.06.2020 в 23:06. Предмет Информатика. Спрашивает Чашка Алина.

Помогите пожалуйста) На языке Pascal составить программу, которая находит номер первого

встречающегося в массиве числа 7.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Пафиков Виктор.
//Предположим, что массив уже дан
var
  NAME_OF_ARRAY : array [1.. 10] of integer := (1,1,7,1,7,1,5,7,4,10);
//Дальше программа. Ей всё равно, какой массив дан, главное, чтобы первый индекс был равен 1
begin
var i : integer := 1;    foreach ai : integer in NAME_OF_ARRAY do
  begin
    if ai = 7 then
      begin
      writeln(i);
      break;
      end
    else
    i += 1;
  end;end.
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос