Вопрос задан 12.06.2020 в 10:03.
Предмет Информатика.
Спрашивает Латц Юлия.
Паскаль: Написать программу для определения в двумерном массиве целых чисел D[6,6] максимальный
элемент под главной диагональю. Оформить ввод/вывод массива.Ответы на вопрос
Отвечает Артемьева Настя.
Var a:array [1..100, 1..100] of integer;
i,j,max:longint;
begin
for i:=1 to 4 do
for j:=1 to 4 do read(a[i,j]);
max:=a[2,1];
for i:=1 to 6 do
for j:=1 to 6 do
if (a[i,j]>max) and (i>j) then max:=a[i,j];
for i:=1 to 6 do begin
for j:=1 to 6 do write(a[i,j],' ');
writeln;
end;
writeln('Максимальный элемент под главной диагональю - ',max);
end.
i,j,max:longint;
begin
for i:=1 to 4 do
for j:=1 to 4 do read(a[i,j]);
max:=a[2,1];
for i:=1 to 6 do
for j:=1 to 6 do
if (a[i,j]>max) and (i>j) then max:=a[i,j];
for i:=1 to 6 do begin
for j:=1 to 6 do write(a[i,j],' ');
writeln;
end;
writeln('Максимальный элемент под главной диагональю - ',max);
end.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 20
Информатика 266
Информатика 34
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
