Вопрос задан 22.05.2020 в 11:58.
Предмет Информатика.
Спрашивает Турсун Али.
Требуется разработать программу, которая получает с клавиатуры координаты точки на плоскости, и
определяет, попадает ли точка в залитую оранжевым область (линии в область не входят). Написать программу нужно двумя способами (можно в одной программе ввести данные, а потом двумя способами получить результат): 1) С применением логических операций 2) С помощью вложенных условных операторов. Разрешается также применение математических функций, арифметических операций. Ответ - текст программы в документе MS Word.
Ответы на вопрос
Отвечает Андрияненкова Татьяна.
Ответ:
Могу подсказать только 1 вариант:
Объяснение:
Module Module1
Sub Main()
Dim x As Single
Dim y As Single
Console.WriteLine("Введите координаты точки x ")
x = Console.ReadLine()
Console.WriteLine("Введите координаты точки y ")
y = Console.ReadLine()
If (x <= 4 And y <= 4 And y >= 4 - x) Or (y <= -4 - x And y >= -4 And x >= -4) Then Console.WriteLine("Точка принадлежит области") Else Console.WriteLine("Точка не принадлежит области")
Console.ReadKey()
End Sub
End Module
Топ вопросов за вчера в категории Информатика
Информатика 18
Информатика 34
Информатика 19
Информатика 26
Информатика 20
Информатика 33
Информатика 31
Информатика 21
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
