Вопрос задан 17.05.2020 в 21:30.
Предмет Информатика.
Спрашивает Шалдыбин Дмитрий.
Помогите пожалуйста написать программу и блок схему. Вот задание: даны две точки: А(x1; y1) и B(x2;
y2) нужно составить программу определяющую, какая из точек находится ближе к началу координат.Ответы на вопрос
Отвечает Поп Михайло.
Var x1,y1,x2,y2,d1,d2:real;
begin
write ('X1 = ');
readln (x1);
write ('Y1 = ');
readln (y1);
write ('X2 = ');
readln (x2);
write ('Y2 = ');
readln (y2);
d1:=sqrt(sqr(x1)+sqr(y1));
d2:=sqrt(sqr(x2)+sqr(y2));
if d1<>d2 then write ('К началу координат ближе ');
if d1>d2 then writeln ('вторая точка') else
if d2>d1 then writeln ('первая точка') else
writeln ('Обе точки равноудалены друг от друга');
end.
begin
write ('X1 = ');
readln (x1);
write ('Y1 = ');
readln (y1);
write ('X2 = ');
readln (x2);
write ('Y2 = ');
readln (y2);
d1:=sqrt(sqr(x1)+sqr(y1));
d2:=sqrt(sqr(x2)+sqr(y2));
if d1<>d2 then write ('К началу координат ближе ');
if d1>d2 then writeln ('вторая точка') else
if d2>d1 then writeln ('первая точка') else
writeln ('Обе точки равноудалены друг от друга');
end.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 25
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
