Вопрос задан 17.05.2020 в 18:14.
Предмет Информатика.
Спрашивает Гришина Мария.
Составьте программу, которая позволяет ввести элементы массива а [1...10] с клавиатуры и выводит на
экран количество отрицательных элементов и их индексы.Ответы на вопрос
Отвечает Хомяк Арина.
Var a:array[1..10] of integer;
b:array[1..10] of integer;
i,k:integer;
begin
for i:=1 to 10 do
begin;
readln(a[i]);
if a[i]<0 then
begin;
k+=1;
b[k]:=i;
end;
end;
writeln('Индексы отрицательных');
for i:=1 to k do
writeln(b[i]);
writeln('Всего:',k);
end.
b:array[1..10] of integer;
i,k:integer;
begin
for i:=1 to 10 do
begin;
readln(a[i]);
if a[i]<0 then
begin;
k+=1;
b[k]:=i;
end;
end;
writeln('Индексы отрицательных');
for i:=1 to k do
writeln(b[i]);
writeln('Всего:',k);
end.
Отвечает Соболев Ян.
Var a:array [1..10] of integer;
i,k:integer;
begin
for i:=1 to 10 do
begin
read(a[i]);
if a[i]<0 then inc(k);
end;
writeln('кол-во элементов:',k);
writeln('их индексы:');
for i:=1 to 10 do
if a[i]<0 then write(i,' ');
end.
i,k:integer;
begin
for i:=1 to 10 do
begin
read(a[i]);
if a[i]<0 then inc(k);
end;
writeln('кол-во элементов:',k);
writeln('их индексы:');
for i:=1 to 10 do
if a[i]<0 then write(i,' ');
end.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 33
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
