Вопрос задан 17.05.2020 в 06:04.
Предмет Информатика.
Спрашивает Галиуллина Айгиза.
Составить программу и блок схему вывода всех чисел от 1000 до 9999, в которых 1 цифра равна 4 и 2
цифра равна 3.Ответы на вопрос
Отвечает Чорнокоза Діма.
Почему-то мой ответ удалили. Напишу подробнее.
Если в чмсле первая цифра 4 и вторая цифра 3, то числа от 4300 до 4399
На паскле программа выглядит так
var i, n: integer
begin
uses crt;
for i:= 0 to 99
begin
n = 4300 + i;
write (n);
end;
writeln;
end.
Блок-схема совсем простая, нарисуй сама.
1) Начало (в овале)
2) i = 0 (в прямоугольнике)
3) n = 4300 + i (в прямоугольнике)
4) Вывод n (в параллелограмме)
5) Проверка i > 99 ? (в ромбе). Если нет, возврат на п. 3. Если да, вниз.
6) Вывод пустой строки (в параллелограмме)
7) Конец (в овале)
Если в чмсле первая цифра 4 и вторая цифра 3, то числа от 4300 до 4399
На паскле программа выглядит так
var i, n: integer
begin
uses crt;
for i:= 0 to 99
begin
n = 4300 + i;
write (n);
end;
writeln;
end.
Блок-схема совсем простая, нарисуй сама.
1) Начало (в овале)
2) i = 0 (в прямоугольнике)
3) n = 4300 + i (в прямоугольнике)
4) Вывод n (в параллелограмме)
5) Проверка i > 99 ? (в ромбе). Если нет, возврат на п. 3. Если да, вниз.
6) Вывод пустой строки (в параллелограмме)
7) Конец (в овале)
Топ вопросов за вчера в категории Информатика
Информатика 47
Информатика 26
Информатика 32
Информатика 70
Информатика 43
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
