Вопрос задан 03.06.2018 в 23:24.
Предмет Информатика.
Спрашивает Ботова Алёна.
ПАСКАЛЬ. Дано натуральное число N. Требуется представить его в виде суммы двух натуральных чисел A
и B таких, что НОД (наибольший общий делитель) чисел A и B — максимален. Входные данные Во входном файле INPUT.TXT записано натуральное число N (2<=N<=109) Выходные данные В выходной файл OUTPUT.TXT выведите два искомых числа A и B. Если решений несколько, выведите то из них, где A принимает наименьшее возможное значение.Ответы на вопрос
Отвечает Шубин Костя.
Если A, B имеют общий делитель d, то и A + B делится на d. Отсюда идея: найдем наибольший делитель N, меньший N, и представим всё в виде d + (N - d). d будем искать так: найдём наименьший делитель q, не равный 1 (если число составное, он не больше корня из N), тогда d = N/q.
var
q, d, n: longint;
isfound: boolean;
begin
readln(n);
isfound := false;
for q := 2 to trunc(sqrt(n)) + 1 do
if n mod q = 0 then
begin
d := n div q;
write(d, ' ', n - d);
isfound := true;
break;
end;
if not isfound then
write(1, ' ', n - 1);
end.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 34
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
