Вопрос задан 06.05.2020 в 00:49.
Предмет Информатика.
Спрашивает Дорофеев Даня.
Это в Паскале. Первая задача: Дана последовательность чисел,оканчивающихся отрицательным числом.
Найти среднее арифметическое введенных положительных чисел. И вторая: Дана последовательность чисел,количество которых заранее не известно. Сколько чисел было введено до первого нуля? Буду очень благодарен,если ответите.Ответы на вопрос
Отвечает Грицкевич Катя.
{1}
var
i, n, s: integer;
begin
i := 0;
writeln('Введите последовательность чисел,оканчивающихся отрицательным числом');
repeat
readln(n);
if n > 0 then begin
s := s + n;
i := i + 1;
end;
until n < 0;
writeln(s / i);
end.
{2}
var
i, n: integer;
begin
i := 0;
writeln('Введите последовательность чисел,оканчивающихся 0');
repeat
readln(n);
if n <> 0 then
i := i + 1;
until n = 0;
writeln(i);
end.
var
i, n, s: integer;
begin
i := 0;
writeln('Введите последовательность чисел,оканчивающихся отрицательным числом');
repeat
readln(n);
if n > 0 then begin
s := s + n;
i := i + 1;
end;
until n < 0;
writeln(s / i);
end.
{2}
var
i, n: integer;
begin
i := 0;
writeln('Введите последовательность чисел,оканчивающихся 0');
repeat
readln(n);
if n <> 0 then
i := i + 1;
until n = 0;
writeln(i);
end.
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 37
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
