Вопрос задан 03.05.2020 в 04:17.
Предмет Информатика.
Спрашивает Снегурьева Настя.
Написать программу паскаль С клавиатуры вводится три числа- коэффициент квадратного уравнения.
Сколько решений имеет уравнение СРОЧНО!Ответы на вопрос
Отвечает Сайпиев Шамиль.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
var
a,b,c: integer;
x,d: real;
begin
repeat
write('Введите коэффициент a (a<>0): ');
readln(a);
until a<>0;
write('Введите коэффициент b: ');
readln(b);
write('Введите коэффициент c: ');
readln(c);
d:=b*b-4*a*c;
writeln('Решение уравнения:');
if d=0 then
writeln('Корень один: х = ',-b/2/a) else
if d<0 then
writeln('Корней на множестве действительных чисел нет') else
begin
writeln('Корней два:');
writeln('1-й корень: x1 = ',(-b-sqrt(d))/2/a);
writeln('2-й корень: x1 = ',(-b+sqrt(d))/2/a);
end;
readln;
end.
Топ вопросов за вчера в категории Информатика
Информатика 31
Информатика 36
Информатика 24
Информатика 43
Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
