
Вопрос задан 01.05.2020 в 14:52.
Предмет Информатика.
Спрашивает Тетерин Даниил.
Составить программу в паскале по блок схеме срочно нужно, помогите пжлст




Ответы на вопрос

Отвечает Миронов Никита.
Var
i,N:integer;
a,d,S,x,y,S1:real;
Begin
Write('N = ');ReadLn(N);
Write('x = ');ReadLn(x);
Write('y = ');ReadLn(y);
S:=0;
S1:=0;
a:=5;
d:=1.7;
For i:= 1 to N do
Begin
S:=S+a;
if a>x then
if a<y then S1:=S1+a;
a:=a+d;
End;
WriteLn('S = ',S);
WriteLn('S1 = ',S1);
End.
i,N:integer;
a,d,S,x,y,S1:real;
Begin
Write('N = ');ReadLn(N);
Write('x = ');ReadLn(x);
Write('y = ');ReadLn(y);
S:=0;
S1:=0;
a:=5;
d:=1.7;
For i:= 1 to N do
Begin
S:=S+a;
if a>x then
if a<y then S1:=S1+a;
a:=a+d;
End;
WriteLn('S = ',S);
WriteLn('S1 = ',S1);
End.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili