Вопрос задан 28.04.2020 в 14:44.
Предмет Информатика.
Спрашивает Chistyakov Maksim.
Задача на Pascal: На вход программы подаются значения элементов трех целочисленный массивов:
А1...А30, В1...В40, С1...Сn(n<=40). Написать программу которая выводит на экран слово "Да", если отрицательный элемент в массиве С встречается раньше, чем в массивах А и В. В противном случае на экран должно быть выведено слово "Нет". Предполагается, что каждый из массивов содержит хотя бы один отрицательный элемент. Заранее Спасибо!Ответы на вопрос
Отвечает Світлик Анастасія.
program raf105;
const
n = 35;
var
a: array[1..30] of integer;
b: array[1..40] of integer;
c: array[1..n] of integer;
i : integer;
begin
writeln('Заполните массив A');
for i:=1 to 30 do
readln(a[i]);
writeln('Заполните массив B');
for i:=1 to 40 do
readln(b[i]);
writeln('Заполните массив C');
for i:=1 to n do
readln(c[i]);
for i:=1 to 40 do
begin
if (a[i] < 0) or (b[i] < 0) then
begin
writeln('Нет');
break
end;
if c[i] < 0 then
begin
writeln('Да');
break
end;
end;
end.
PascalABC
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
