Вопрос задан 19.04.2020 в 16:24.
Предмет Информатика.
Спрашивает Росьянский Андрей.
Pascal. Составить программу, которая печатает true, если точка с координатами (х,у) принадлежит
заштрихованной области
Ответы на вопрос
Отвечает Егоров Денис.
Область может быть описана как совокупность двух отдельных областей.

var
x, y: real;
p, q: boolean;
begin
Write('Введите через пробел координаты x,y: ');
Readln(x, y);
p := (x >= 0) and (y >= 0) and (sqr(x) + sqr(y) <= 25);
q := (x >= -5) and (x<=0) and (abs(y) <= x + 5);
Writeln(p or q)
end.
Примеры выполнения программы:
Введите через пробел координаты x,y: -2 1
True
Введите через пробел координаты x,y: -4 2
False
Введите через пробел координаты x,y: 3 3
True
Введите через пробел координаты x,y: 6 3
False
var
x, y: real;
p, q: boolean;
begin
Write('Введите через пробел координаты x,y: ');
Readln(x, y);
p := (x >= 0) and (y >= 0) and (sqr(x) + sqr(y) <= 25);
q := (x >= -5) and (x<=0) and (abs(y) <= x + 5);
Writeln(p or q)
end.
Примеры выполнения программы:
Введите через пробел координаты x,y: -2 1
True
Введите через пробел координаты x,y: -4 2
False
Введите через пробел координаты x,y: 3 3
True
Введите через пробел координаты x,y: 6 3
False
Отвечает Мулдашев Дияр.
Var x,y,c,d:integer;
begin
readln(x,y);
if (((x*x+y*y)<=25) and (x>=0) and (x<=5) and (y>=0) and (y<=5))
or ((-x-5<=y) and (x>=-5) and (x<=0) and (y<=0) and (y>=-5))
or ((x+5>=y) and (x>=-5) and (x<=0) and (y>=0) and (y<=5))
then
writeln('true');
end.
begin
readln(x,y);
if (((x*x+y*y)<=25) and (x>=0) and (x<=5) and (y>=0) and (y<=5))
or ((-x-5<=y) and (x>=-5) and (x<=0) and (y<=0) and (y>=-5))
or ((x+5>=y) and (x>=-5) and (x<=0) and (y>=0) and (y<=5))
then
writeln('true');
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
