
Вопрос задан 18.04.2020 в 03:23.
Предмет Информатика.
Спрашивает Корнеенко Валерия.
Напишите программу, создающую матрицу с рандомными числами. Далее она должна определить наибольшее
число в строке и вывести его напротив этой строки. Также и со столбцами. Язык- паскаль


Ответы на вопрос

Отвечает Подольная Настя.
Var i, j,s,k, max:Integer;
A:array[1..10, 1..10] of Integer ;
Begin
Randomize ;
Max:=0;
For i:=1 to 3 do begin
Writeln;s:=0;
For j:=1 to 3 do begin
A[i,j]:=random(10) ;
Write(' ', A[i,j]);
If A[i, j]>s then
s:=A[i, j];end;
If s>max then max:=s;
Write(' ', s) ;End;writeln;
For j:=1 to 3 do begin
K:=0;
For i:=1 to 3 do begin
If A[i, j]>k then k:=A[i, j];end;
Write(' ', k) ;end;
Write(' ', max) ;
End.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili