Вопрос задан 15.04.2020 в 10:43.
Предмет Информатика.
Спрашивает Гришин Сергей.
Составить программу для вычесления площади и периметра треугольника(известны все три стороны) при
двух условиях: если треугольник прямоугольный и если нет, то через формулу герона. В Паскале нужна программаОтветы на вопрос
Отвечает Шаброва Юлия.
Program zadanie;
var a, b, c, s, p, pp:real;
begin
writeln('Введите сторону a');
read(a);
writeln('Введите сторону b');
read(b);
writeln('Введите сторону c');
read(c);
p:=a+b+c;
pp:=p/2;
if (sqr(a)=sqr(b)+sqr(c)) then
begin
writeln('Прямоугольный треугольник с гипотенузой a');
s:=1/2*b*c;
writeln('Площадь = ',s);
end;
if (sqr(b)=sqr(a)+sqr(c)) then
begin
writeln('Прямоугольный треугольник с гипотенузой b');
s:=1/2*a*c;
writeln('Площадь = ',s);
end;
if (sqr(c)=sqr(b)+sqr(a)) then
begin
writeln('Прямоугольный треугольник с гипотенузой c');
s:=1/2*b*a;
writeln('Площадь = ',s);
end
else
begin
writeln('Непрямоугольный треугольник');
s:=sqrt(pp*(pp-a)*(pp-b)*(pp-c));
writeln('Площадь = ',s);
end;
writeln('Периметр = ',p);
end.
var a, b, c, s, p, pp:real;
begin
writeln('Введите сторону a');
read(a);
writeln('Введите сторону b');
read(b);
writeln('Введите сторону c');
read(c);
p:=a+b+c;
pp:=p/2;
if (sqr(a)=sqr(b)+sqr(c)) then
begin
writeln('Прямоугольный треугольник с гипотенузой a');
s:=1/2*b*c;
writeln('Площадь = ',s);
end;
if (sqr(b)=sqr(a)+sqr(c)) then
begin
writeln('Прямоугольный треугольник с гипотенузой b');
s:=1/2*a*c;
writeln('Площадь = ',s);
end;
if (sqr(c)=sqr(b)+sqr(a)) then
begin
writeln('Прямоугольный треугольник с гипотенузой c');
s:=1/2*b*a;
writeln('Площадь = ',s);
end
else
begin
writeln('Непрямоугольный треугольник');
s:=sqrt(pp*(pp-a)*(pp-b)*(pp-c));
writeln('Площадь = ',s);
end;
writeln('Периметр = ',p);
end.
Топ вопросов за вчера в категории Информатика
Информатика 18
Информатика 34
Информатика 19
Информатика 26
Информатика 20
Информатика 33
Информатика 31
Информатика 21
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
