
Вопрос задан 10.04.2020 в 03:46.
Предмет Информатика.
Спрашивает Попов Коля.
Помогите пожалуйста с языком паскаля, срочно надо. 1) написать программу, которая удаляет из строки
заданное количество символов. 2) написать программу, которая выставляет в строку подстроку. 3) написать программу подсчитывающую количество знаков $ в вводимой строке.

Ответы на вопрос

Отвечает Лубенец Елизавета.
Var strok: string; n,k: integer;
begin
writeln('введите строку');
readln(strok);
writeln('с какого по счёту символа начать удаление?');
readln(n);
writeln('сколько символов удалить?');
readln(k);
delete(strok, n, k);
writeln(strok);
end.
это первая
var strok,strok2: string;
n: integer;
begin
writeln('введите строку');
readln(strok);
writeln('с какого символа по счёту вставить строку?');
readln(n);
writeln('какую строку вставить?');
readln(strok2);
insert(strok2 ,strok, n);
writeln(strok);
end.
это вторая, а третья в коментах, иначе не влезет
begin
writeln('введите строку');
readln(strok);
writeln('с какого по счёту символа начать удаление?');
readln(n);
writeln('сколько символов удалить?');
readln(k);
delete(strok, n, k);
writeln(strok);
end.
это первая
var strok,strok2: string;
n: integer;
begin
writeln('введите строку');
readln(strok);
writeln('с какого символа по счёту вставить строку?');
readln(n);
writeln('какую строку вставить?');
readln(strok2);
insert(strok2 ,strok, n);
writeln(strok);
end.
это вторая, а третья в коментах, иначе не влезет


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili