Вопрос задан 09.04.2020 в 09:44.
Предмет Информатика.
Спрашивает Тимошенко Коля.
С++. Напишите программу, которая выводит в одну строчку все делители переданного ей числа, разделяя
их пробелами. Делать через процедуруОтветы на вопрос
Отвечает Sapargalieva Inkar.
#include <iostream>
using namespace std;
int main()
{
int n;
cin >> n;
for (int i = 1; i <= n; ++i)
{
if (n % i == 0)
{
cout << i << " ";
}
}
}
using namespace std;
int main()
{
int n;
cin >> n;
for (int i = 1; i <= n; ++i)
{
if (n % i == 0)
{
cout << i << " ";
}
}
}
Отвечает Губарев Олег.
12345678910111213141516171819202122Program task7; Var i : integer; procedure PrintAllDividers(n : integer; p : integer); Begin if (p <= (n div 2)) then Begin if (n mod p) = 0 then Begin write(p); write(' '); end; PrintAllDividers(n,p+1); end;End; Begin write('i='); readln(i); PrintAllDividers(i,1); writeln;End.
Топ вопросов за вчера в категории Информатика
Информатика 68
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
