Вопрос задан 08.04.2020 в 07:51.
Предмет Информатика.
Спрашивает Гринцевич Илья.
Составьте программу(Паскаль) для определения количества цифр в записи произвольного натурального
числа. Сейчас проходим while, судя по всему его и надо использовать.Ответы на вопрос
Отвечает Кимсанов Шероз.
Var n,p,k:integer;
begin
readln (n);
p:=n;
while p<> 0 do begin
k:=k+1;
p:=p div 10;
end;
writeln ('k=',k);
end.
begin
readln (n);
p:=n;
while p<> 0 do begin
k:=k+1;
p:=p div 10;
end;
writeln ('k=',k);
end.
Топ вопросов за вчера в категории Информатика
Информатика 25
Информатика 45
Информатика 13
Информатика 62
Информатика 21
Информатика 116
Информатика 10
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
