
Вопрос задан 26.03.2020 в 18:43.
Предмет Информатика.
Спрашивает Федоткина Арина.
В двумерном массиве хранится информация о зарплате 20 человек за каж- дый месяц года (первого
человека — в первой строке, второго — во вто- рой и т. д.). Составить программу для расчета общей зарплаты, полученной за год любым человеком, информация о зарплате которого представлена в массиве.

Ответы на вопрос

Отвечает Ковешникова Юлия.
Var a:array[1..12,1..20] of real;
i,j,n:integer;
s:real;
begin
// Заполним массив случайными значениями для теста
for i:=1 to 12 do
for j:=1 to 20 do
a[i,j]:=random*20000;
writeln('Номер сотрудника ');
readln(n);
for i:=1 to 12 do
s:=s+a[i,n];
writeln('Зарплата за год ',s);
end.
i,j,n:integer;
s:real;
begin
// Заполним массив случайными значениями для теста
for i:=1 to 12 do
for j:=1 to 20 do
a[i,j]:=random*20000;
writeln('Номер сотрудника ');
readln(n);
for i:=1 to 12 do
s:=s+a[i,n];
writeln('Зарплата за год ',s);
end.



Отвечает Закиров Нурсаид.
Паскаля нет под рукой, но я себе это представляю как-то так...


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili