
Вопрос задан 21.03.2020 в 03:04.
Предмет Информатика.
Спрашивает Смирнова Алина.
В паскале составить программу которая для натуральных чисел m и n находит min(2n,m)*nod(2n,3m)


Ответы на вопрос

Отвечает Васильев Илья.
PascalABC.NET 3.x
function Gcd(a,b:integer):integer; // НОД
begin
while b<>0 do begin a:=a mod b; Swap(a,b) end;
Result:=a
end;
begin
var m,n:integer;
Read(n,m);
Writeln(Min(2*n,m)*Gcd(2*n,3*m))
end.
Пример
12 43
72
function Gcd(a,b:integer):integer; // НОД
begin
while b<>0 do begin a:=a mod b; Swap(a,b) end;
Result:=a
end;
begin
var m,n:integer;
Read(n,m);
Writeln(Min(2*n,m)*Gcd(2*n,3*m))
end.
Пример
12 43
72


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili