Вопрос задан 15.03.2020 в 20:57.
Предмет Информатика.
Спрашивает Межуев Данил.
Помогите написать программу на С++. Дан массив, состоящий из целых чисел. Известно, что числа
упорядочены по неубыванию (то есть каждый следующий элемент не меньше предыдущего). Напишите программу, которая определит количество различных чисел в этом массиве. Входные данные Сначала задано число N — количество элементов в массиве (1N100). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел. Выходные данные Необходимо вывести единственное число - количество различных чисел в массиве. Примеры входные данные 5 1 1 1 1 1 выходные данные 1Ответы на вопрос
Отвечает Хлопков Женя.
#include <iostream>
int main(){
int n;
int i,j,col;
int a[100];
for (i=1;i<=100;i++){
a[i]=0;
}
std::cin>>n;
bool f;
col=0;
for (i=1;i<=n;i++){
f=true;
std::cin>>a[i];
for (j=1;j<i;j++){
if (a[i] == a[j]){
f=false; }
} i
f (f){ col++; }
}
std::cout<<col;
}
int main(){
int n;
int i,j,col;
int a[100];
for (i=1;i<=100;i++){
a[i]=0;
}
std::cin>>n;
bool f;
col=0;
for (i=1;i<=n;i++){
f=true;
std::cin>>a[i];
for (j=1;j<i;j++){
if (a[i] == a[j]){
f=false; }
} i
f (f){ col++; }
}
std::cout<<col;
}
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
