Вопрос задан 17.02.2020 в 15:57.
Предмет Информатика.
Спрашивает Гирченко Стас.
Составить программу для вычисления корня нелинейного уравнения по методу касательных х^2-cos(x^2)=6
Ответы на вопрос
Отвечает Изтурганов Бекзат.
Для метода касательных (он же - метод Ньютона) надо задать начальное приближение и получить выражение для производной функции.

Рекуррентная формула в методе Ньютона имеет следующий вид:

Для нашей конкретной задачи можно записать:

А еще надо задать погрешность решения, которую определим так:

function f(x:real):real;
begin
f:=sqr(x)-cos(sqr(x))-6
end;
function fn1(x:real):real;
begin
fn1:=x-(sqr(x)-cos(sqr(x))-6)/(2*x*(1+sin(sqr(x))))
end;
var
xn,xn1,y,eps:real;
begin
Writeln('Введите начальное приближение для корня: ');
Read(xn);
Writeln('Введите значение погрешности для решения: ');
Read(eps);
xn1:=xn; y:=f(xn);
while abs(y)>eps do
begin xn1:=fn1(xn); y:=f(xn1); xn:=xn1 end;
Writeln('x=',xn1,' f(x)=',y)
end.
Тестовое решение:
Введите начальное приближение для корня:
-3
Введите значение погрешности для решения:
0.00001
x=-2.61645602631473 f(x)=1.28691349221555E-06
Рекуррентная формула в методе Ньютона имеет следующий вид:
Для нашей конкретной задачи можно записать:
А еще надо задать погрешность решения, которую определим так:
function f(x:real):real;
begin
f:=sqr(x)-cos(sqr(x))-6
end;
function fn1(x:real):real;
begin
fn1:=x-(sqr(x)-cos(sqr(x))-6)/(2*x*(1+sin(sqr(x))))
end;
var
xn,xn1,y,eps:real;
begin
Writeln('Введите начальное приближение для корня: ');
Read(xn);
Writeln('Введите значение погрешности для решения: ');
Read(eps);
xn1:=xn; y:=f(xn);
while abs(y)>eps do
begin xn1:=fn1(xn); y:=f(xn1); xn:=xn1 end;
Writeln('x=',xn1,' f(x)=',y)
end.
Тестовое решение:
Введите начальное приближение для корня:
-3
Введите значение погрешности для решения:
0.00001
x=-2.61645602631473 f(x)=1.28691349221555E-06
Топ вопросов за вчера в категории Информатика
Информатика 20
Информатика 23
Информатика 22
Информатика 29
Информатика 21
Информатика 20
Информатика 26
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
